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GYPRO®-EVB2 or AXO®-EVB3 Arduino MO or Arduino Yun Tronics
(as delivered by Tronics) + USB cable Evaluation Tool
(to be purchased separately)
P

GYPRO2300

(type A/type MicroB)
GYPRO2300LD
GYPRO3300
or AX0215

& = —

Software supplied
by Tronics

Arduino MO board
or Arduino Yun Board

©00000000000000000000000000000000000000000000000000000000000000000000000000

©0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000

Features

This user manual is intended for customers who have purchased GYPRO®-EVB2 or AXO®-EVB3 Evaluation Board and who would
like to implement it using Arduino platform. The following paragraphs explain how to set-up the full evaluation kit and how to
configure Arduino MO or Yun board.

Required:
- GYPRO®-EVB2 or AXO®-EVB3
- Header Connectors (x5)
- Tronics USB Flash drive.
- Arduino MO board or Arduino YUun Rev. 2 Board (not included).
- Micro-B USB Cable (not included).
- Computer running Window 7 or later version with USB port.

Supplied by Tronics

Note: If you intend to perform tests over temperature, make sure that your USB Cable can withstand the operating temperature
range specified by Tronics
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1. System Requirements

Tronics Evaluation Tool software is compatible with OS Windows 7 or later versions. The program automatically adapts to the
operating system on which it runs, eliminating the need for manual settings.

Recommended system configuration:

*  Processor 1.6 GHz or faster

. 2 GB RAM

*  1280%*960 pixels minimal screen resolution

* 780 MB free hard disk space for the Arduino IDE and the Tronics Evaluation Tool software (additional space is needed
during installation only to accommodate the initial setup files).

* USB Port.

*  Operating Systems: Windows 7, Windows Server 2008 R2, Windows Thin PC, Windows 8 / 8.1, Windows RT, Windows
Server 2012 and Windows 10.

2. Setting Up
2.1. Installing Arduino IDE
1. Plugthe USB flash drive directly into an available USB port.

NOTE: A message indicating that a new device has been detected should appear at the lower right hand of your screen. It
may take a few seconds to be detected.

2. If the USB flash drive or external drive folder does NOT open automatically, follow these steps:

a. Click Start > Computer.
b. Double-click on the “TRONICS USB” associated with the USB flash drive.

Ega_ » Ordinateur » TRONICS USBE (F:) »

Organiser » Partager avec » Graver Nouveau dossier
<% Favoris Nom Modifié le Type Taille
=l Emplacements récents .. Arduino Firmware & IDE 17/01/2017 10:17 Dossier de fichiers
& Téléchargements . Documentations 08/11/2016 12:05 Dossier de fichiers
Bl Bureau ./ Tronics Evaluation Tool Software 11/10/2016 16:32 Dossier de fichiers
. Tutorial videos 11/10/2016 16:36 Dossier de fichiers
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Double-click on “Installation” folder then on arduino-
1.X.X.windows.exe and proceed with the installation
(please authorize the driver installation process).

NOTE: The latest version of this software is also
available on our website.

e - X

Check the components you want to install and uncheck the components
you don't want to install. Click Next to continue.

Select components to install: Install Arduino software
Install USB driver

Create Start Menu shortout
Create Desktop shortout

Assodate .ino files

Space required: 392, 7MB

Cancel | Mullsoft Install System w2, 46 < Back Mext =

Select all the components and then click on “Next”
button.

Choose the installation directory (we suggest to keep
the default one) then click on the “Install” button.

@ Arduino Setup: Installation Folder — x

Setup will install Arduino in the following folder. To install in a different
52 folder, dick Browse and select another folder. Click Install to start the
installation.

"Desﬁnaﬁcn Folder

C: \Program Files (x86) VArduing

Browse... |

Space required: 332.7MB
Space available: 24.6G8

Cancel | Nullsaft Install System vz, 46 < Back

6. The process will extract and install all the required

files to execute properly the Arduino Software (IDE).

@ Arduino Setup: Installing -

e Extract: c++.exe
. L]

Canrcel | ullsaft Install System v2.46 < Bark | Close

7. The installation of Arduino IDE includes “Atmel USB

Driver Package” installation. You don’t need to install

tronicslil
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8.

this package if you don’t use other boards than the
Arduino MO in the future.

® Atmel USB Driver Package Setup - >

,’\ Atmel USB Driver Package

Modify Setup

Repair Uninstall Close

Once the status “Completed” is displayed, Arduino
IDE is installed and is ready to be used. You can close
the Installer.

@ Arduine Setup: Completed —

Completed

.0)

Show details |

Cancel |

Mullsoft Install System

< Back | Close
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2.2. Configuring Arduino Board (Case
Arduino MO0)

Connect the Arduino MO board to your computer using
the USB cable and the Native USB Port. If this is the first
time you are connecting an Arduino MO Board to your
computer, please wait a few minutes before going on,
as Windows needs to install all the necessary drivers.
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6. Select the serial port number corresponding to the

Arduino board in the Tools > Port menu. The name
“Arduino M0Q” should be associated with the correct
COM port.

Auto Format
Archive Sketch
Fix Encoding & Reload

Serial Moniter

Ctrl+ShiftsM |/ E S S B RS ES L

Board

Port Serial ports
comt
com3
¥ COMS (Arduino MD) |

Programmer

Burn Bootloader

7. Now, you need install Tronics EVB Library : Click on
“Add .ZIP Library...” in the Sketch > Include Library

menu.

(=2l sketch_may24a | Ar

File Edit Tools Help
Verify/Compile Crrl+R
Upload Ctrl+U

Upload Using Programmer  Ctrl+Shift+U

2. Open Arduino IDE.

Export compiled Binary Ctrl+Alt+S
Show Sketch Folder Ctrl+K
" "’y
3. Open the “Boards Manager”’ in the Tools > Board Include Library A
menu : Add File... Manage Libraries...
B sketch_may23a] A 7| // put your main code here, to run repg Add ZIP Library... |
File Edit Sketch Help ol [ R [
Auto Format Ctel+T
Archive Sketch
sketch_may24) “ . . . . ” o “ .
ety 8. Select “TronicsEvaluationKit_Library” in the “Arduino
1 void setug Serial Monitor Ctrl+Shift+ M -
2T swtpta ol shiteL Firmware & IDE” folder into the USB flash drive.
sl WFiL01 Firmware Updater
il 1
6|void loop Board: "Arduina M0" - “ . ” £ .
S [ oards anager.. 9. Now, you can open “EvaluationTool” firmware in the
o) et Board Info e SRR T AT Lo RO ECur et
Arduino/Genuino Zero (Programming Port) Examples menu.
Programmer Arduino/Genuino Zero (Native USB Port] bvaliaoniol |
Bum Bootloader Arduino/Genuino MKRLO0D [File] Edit._Sketch Tools Help
Arduino MKRZero e Ctri+N
Arduino MKRFox1 200 Open.. CHie0
BAfrat et Blarenind vnrece S
Sketchbook
. n . . B &
4. Install latest version of "Arduino SAMD Boards (32-Bits anEicy O ,
Close CtrieW :
n
ARM Cortex MO+) Save — oo.use ,
o s == Sovefs..  CtrleShiftsS ﬂ‘i:‘ﬁ”(‘;:“‘“t :
Arduinol
Tyse [l <) [Fter your earch... PageSetup  Ctrls Shift=P
Arduino SAM Boards (32-bits ARM Cortex-M3) by Arduino - Print Ctrl+P Examples for any board
8o uded in this packsge: Adafruit Circuit Playground ¥
i Preferences  Ctrl+Comma A — N
Quit Cri+Q Bridge s
e ) by Arduine ] 45 #include <EVB.h> /f Re Tronics Evaluation KitLibraryI AY0 BaadOutnut
uded n this package: 16
e e 27 |voia setup0) 1 INCOMPATIBLE EvaluationTool
48 EVB.Init (RRDUINO_CUTH v GYPRO_ReadOutput

16.12v

Intel i586 Boards by Intel ‘ | |

10. Upload the program: Simply click on the "Upload"
button in the environment. Wait a few seconds, and
you should see the RX and TX LEDs on the board
flashing. If the upload is successful, the message "Done

Fetmodrs: s uploading." will appear in the status bar at the bottom

: of the window.

5. Select “Arduino M0” in the Tools > Board menu.
D sketch moy2ts | Arcine S

B sketch_may24a | An

File Edit Sketch Help

Auto Format CtrisT

Archive Sketch

sketch_may24)

Fix Encoding & Reload

: i WiFi101 Firmware Updater
/7 put § e Boards Manager...

ol Get Board Info Atduin SAMD (32-bits ARM Cortex-Mo-+) Boards

Arduino/Genuino Zero (Programming Port) .
posamme Arduino)Genino Zero (Native USE Port) 11. Close Arduino IDE
‘Arduino/Genuino MKR1000
‘Arduino MKRZero
Arduine MKRFo:x1200
G = NOW YOUR ARDUINO MO BOARD IS PROGRAMMED AND
q D
S READY TO BE USED WITH TRONICS EVALUATION TOOL.
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2.3. Configuring Arduino Board (Case Arduino Yun)
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1. Connect the Arduino Yun board to your computer
using the USB cable and the USB Port. If this is the first 5. Now, you need install Tronics EVB Library : Click on
time you are connecting an Arduino Yun Board to your “Add .ZIP Library...” in the Sketch > Include Library
computer, please wait a few minutes before going on, menu.
as Windows needs to install all the necessary drivers. e —
Verify/Compile Ctrl+R
Upload Ctrl+U
Upload Using Programmer  Ctrl+Shift+U
Export compiled Binary Ctrl+Alt+S
Show Sketch Folder Ctrl+K
Include Library A ‘
; Add File.. Manage Libraries...
7| 4/ put your main code here, to run tepd  Add ZIP Libray.. |
6. Select “TronicsEvaluationKit_Library” in the “Arduino
Firmware & IDE” folder into the USB flash drive.
7. Now, you can open “EvaluationTool” firmware in the
Examples menu.
EvaluationTool | Arduino 1.85
2. Open Arduino IDE. [File] Edit Sketch Tools Help
MNew Ctrl+N
Open... Ctri+O
3. Select “Arduino Yun” in the Tools > Board menu. o esert
EvaluationTool | Arduino L85 E:tc . oo A
File Edit Sketch Help ci:: = o 08.Strings 3
Auto Format Crl+T S Ctrl+S 09.UsB 4
Archive Sketch SaveAs. Chrl+Shift+5 10.5tarterKit_BasicKit 4
EvaluationToel gy Encoding & Reload 11 ArduinoISP '
L[ rennnnnnns Serial Manitor CrleShifta M |75 Page Setup  Ctrl+ Shift-P
R Serial Plotter Ctrl+Shift+L Print Ctrl+P A
3 Adafruit Circuit Playground ¥
4 WiFiLO1 Firmuware Updater Preferences  Ctris Comma ArduinoCloud v
6 Board: “Arduino Vin" A Qs SHEE i o T
7 Port Boards Manager... 45 #include <BVB.h> // B Tronics Evaluation Kit Library ) seme¥QuRaadOutast
; Get Board Info Arduino AVR Boards :, ord setun () { INCOMPATIBLE EvaluationTool
10 — —— ©  Arduino Yin 4z EVB.Init (ARDUINO_OUTH 9 GYPRO_ReadOutput
11 regrammer: m AIUUINIDY QENUIny Uy
E B Eurs Dot o Arduine Duemilanove or Diecimila
u AT 8. Upload the program: Simply click on the "Upload"
button in the environment. Wait a few seconds, and
4. Select the serial port number corresponding to the you should see the RX and TX LEDs on the board

Arduino board in the Tools > Port menu. The name
“Arduino Yun” should be associated with the correct

COM port.

EvaluationTool | Arduino 1.8.5

flashing. If the upload is successful, the message "Done
uploading." will appear in the status bar at the bottom

of the window.

File Edit Sketch |Tools| Help

9. Close Ard

= NOW YOUR
READY TO BE USE

Auto Format Ctrl+T
Archive Sketch
EvaluationToo Fix Encoding & Reload
1 Serial Moenitor Crl+Shift+M
; Serial Plotter Ctrl+Shift+L
N WiFil01 Firmware Updater
2
& Beard: "Arduine Yin" L3
) Port
g9 Get Board Info
10
11 Programmer: "AVRISP midl" L4
12 This Burn Bootloader
13
14 Tronics Fvaluation Tanl is free anfrware:

Serial ports
COM20 {Arduino Yuan) b,

déEoo... @

uino IDE

ARDUINO YUN BOARD IS PROGRAMMED AND
D WITH TRONICS EVALUATION TOOL.
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2.4. Assembling GYPRO®-EVB2 or AXO®-EVB3 with Arduino Board

1. Disconnect your Arduino board from the computer, since the Arduino Board should be switched-off for the next step.
2. (Only for AXO®-EVB3): Add a Jumper to J9 connector between “3V3/EXT” and “VDDIO REF” pins. This will apply the same
reference voltage for SPI signals as the Arduino board.
R2
X
E
3
N
3.

Plug the GYPRO® or AXO® Evaluation Board on the Arduino Board, using the 5 connectors supplied by Tronics. The correct
position is to have the Arduino board on top (above the Evaluation board).

-\ / Arduino board

— Header connectors

\ GYPRO®-EVB2

or
AXO®-EVB3

4. Connect the Arduino Board to your computer using the USB cable and the Native Port.

5. Now you can launch Tronics Evaluation Tool.exe software on your computer!
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3. Basic Operation of Tronics Evaluation Tool Software
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The Evaluation Tool is made of 5 tabs:

Reading GYPRO® / AXO® (Main Tab):

Reads the sensor data (Angular rate / Linear
Acceleration and Temperature) and displays them
on two real-time charts.

System Register (SR):

Enables reading, writing or changing the output
format of the data (Raw, Compensated or
Calibrated) by modifying the sensor System
Register.

Multi-Time-Programmable (MTP):

Useful to read and program new temperature
compensation coefficients in the MTP of the
sensor.

Others:

To check Software and Hardware Self-Test, to read
Drive Frequency, to measure Start-Up Time and to
generate debug reports for Tronics support team.

B

Acquisition Time (s) :

e Compass / Plane:

Displays a real-time compass using GYPRO® or a

plane using AXO®.

Arduino MO Mative Port (COM10)
EVB 3.0
AX0215: 1979711488
Connected !

Data Rate (Hz) :

Once the Arduino board is detected by the software, you can click on the top left power ON/OFF button. The application will
start and read the sensor information (serial number and type of sensor).

Choose an Acquisition time (1s minimum) and a Data Rate (from 1 to 2000 Hz) and click on the “Start/Stop” button.

Arduino MO Native Port (COM10)

tronicslel

Power EVB3.0
J AX0215:1979711488
button Connected !
Acceleration Output (g) :
Acquisition Time (s) : Data Rate (Hz) :
30 1800
Start/Stop
button START
Temperature Output (LSB)
File Name :
Record Acquisiion [ ]
Folder Path :

Self Test:
No reading

Angle:

|
No reading Lo

microsystems

=> FOR DETAILED DESCRIPTION OF TRONICS EVALUATION TOOL SOFTWARE PLEASE READ THE DOCUMENT TRONICS EVALUATION KIT —

SOFTWARE USER MANUAL
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The following tools and resources are available on GYPRO® and AXO® webpages of Tronics website.

Item Description ‘

Documentation & technical notes

)
AXO0215 - Datasheet

GYPRO2300 / GYPRO2300LD - Datasheet

GYPRO3300 - Datasheet

Mechanical tool

| W— GYPRO3300 - 3D model

Evaluation kit

AXO®-EVB3 — Evaluation board
Evaluation board for AXO215, compatible with Arduino MO and Arduino Yun

GYPRO®-EVB2 — Evaluation board
Evaluation board for GYPRO2300, 2300LD and 3300, compatible with Arduino MO and
Arduino Yin

Tronics Evaluation Tool — Software

I
Evaluation
&
AXO®-EVB3 — User manual
&
GYPRO®-EVB2 — User manual
oo
2,,0. Tronics Evaluation Kit — Quick Start Guide
Q Tronics Evaluation Tool — Software User Manual

Tronics Evaluation Tool — Arduino Firmware

Should you encounter any issue while using GYPRO® or AXO® Evaluation Kit, please contact Tronics technical support by
sending an email to support@tronicsqroup.com.
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